Opened 8 years ago

Closed 8 years ago

#226 closed defect (invalid)

AVC encoded video tracks have incorrect "Format" string in QTP Inspector window

Reported by: avidrissman Owned by:
Priority: normal Milestone:
Component: Perian-Main Version: 1.0
Severity: normal Keywords:
Cc:

Description

I have a movie with an AVC video track and an AAC audio track. In the Inspector window, the audio track, under "Format", says: "AAC, Stereo (L R), 44.100 kHz". Looks good.

The video track, though, under "Format", says: "VC Coding<<about 25 bytes of junk>>, 622 x 472, Millions".

Every AVC-encoded file displays like that. Being an old-school Mac guy, that screams to me that something should have been a Pascal string rather than a C string, but I'll leave that to you.

Attachments (1)

sample.mov (4.6 KB) - added by avidrissman 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by avidrissman

comment:1 Changed 8 years ago by dconrad

Is this with QuickTime 7.2? This seems like a dupe of #126, which was fixed for me with that update.

comment:2 follow-up: Changed 8 years ago by Ritsuka

That is an HandBrake? bug, it just write garbage in the "name" field of the stsd atom.
You can use dumpster to change it.

comment:3 in reply to: ↑ 2 Changed 8 years ago by dconrad

  • Resolution set to invalid
  • Status changed from new to closed

Replying to Ritsuka:

That is an HandBrake? bug, it just write garbage in the "name" field of the stsd atom.
You can use dumpster to change it.

Seems so. I posted a patch to HandBrake?'s forum which fixes this in theory (http://handbrake.m0k.org/forum/viewtopic.php?p=12294). QuickTime's normal behaviour from what I've seen is to show what the stsd says is the codec name in Get Info, and fall back to the decoder's cdci info only if that's null. Showing the junk matches with that, and since we don't have any control over the stsd for .mov/.mp4 files, I'd put this down to a QuickTime bug.

Note: See TracTickets for help on using tickets.