Ticket #233 (closed defect: duplicate)

Opened 7 years ago

Last modified 4 years ago

Annoying video delay with multiple VP6/MP3 tracks in a .mov

Reported by: Adreitz Owned by:
Priority: normal Milestone:
Component: decompression Version: 1.0
Severity: normal Keywords:
Cc:

Description

Let's imagine that there is a US cable channel that often plays anime at night during a programming block that I will refer to as "AS". And let's imagine that on AS's web site, they have a streaming video service for episodes of their shows, served by a shockwave interface in .FLV format (VP6/MP3 audio and video). And let's suppose that each episode is broken up into four different files, which I download using Safari's Activity window, use Perian to open in QuickTime Player, assemble them in order in a single movie, and save (without reencoding) as a self-contained .mov file. This file will then have four audio-video track pairs, played one after another with no breaks.

When I open this file in iTunes or QT Player to play at a later time, I notice that at the beginning of each of the four sections of the file there will be a variable-length pause in the video while the audio plays normally. Sometimes it is unnoticeable, and other times the video window will sit blank for eight to ten seconds before showing again (it won't then be out of sync with the audio - it starts playing the video at the proper place). This is annoying, because I then have to rewind and replay the part I missed, and it's a possibility that the initial portion still won't load properly. And since it happens at the beginning of each track change (possibly including the beginning of the file itself), that adds to the annoyance. It would be nice if Perian would start preloading the next track before playback gets to it, to avoid the delay.

Scrubbing through the entire length of the movie will not get all of the sections to load. It seems to require that section to be played for a certain length of time, and afterward that portion will stay loaded even if playback moves to another section. So if I immediately played the file again without closing it, it would play smoothly.

Do any of the developers have a solution to this? Can anyone else reproduce this? I have not verified whether this requires VP6 video, but I suspect it at least requires a video format that QT needs Perian to play.

Aaron

2x1.8 GHz G4 1.5 GB RAM 10.4.10 QT 7.2 Perian 1.0

Change History

comment:1 in reply to: ↑ description Changed 7 years ago by gbooker

Replying to Adreitz:

assemble them in order in a single movie, and save (without reencoding) as a self-contained .mov file. It would be nice if Perian would start preloading the next track before playback gets to it, to avoid the delay.

Sounds to me like an issue with Quicktime. Perian does not handle loading from the file from .mov file sources, Quicktime does.

BTW, is the CPU pegged during this transition?

comment:2 follow-up: ↓ 3 Changed 7 years ago by brilliantpebble

I've had the same problem with a video delay with Truemotion VP6/MP3 files downloaded as flv's, but without the joining clips. That is, unlike the original poster, let's say I download a single clip; when I open it in QuickTime, let it load fully (although this happens with very short clips too), the video will hang for 7 seconds while the audio plays, and then the video will jump to catch up, and then things will go smoothly. But I've also noticed that this did not happen with Perian 0.5. I just downgraded and everything works fine -- the same clip plays instantly.

BTW, I think that when the original poster referred to loading .mov files, he/she just meant that when you open an .flv with QuickTime, it will try to save it in order to give it a .mov extension, but it doesn't reencode anything, i.e. the file is still VP6/MP3. So it seems like Perian does handle these (since they won't play without it).

MacBook? Pro 2GHz, Intel Core Duo, OS 10.4.10

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 7 years ago by gbooker

Replying to brilliantpebble:

I've had the same problem with a video delay with Truemotion VP6/MP3 files downloaded as flv's, but without the joining clips.

Can you provide a sample or a URL to such a file

BTW, I think that when the original poster referred to loading .mov files, he/she just meant that when you open an .flv with QuickTime, it will try to save it in order to give it a .mov extension, but it doesn't reencode anything, i.e. the file is still VP6/MP3. So it seems like Perian does handle these (since they won't play without it).

I knew exactly what the original poster meant, and you are correct. My statement reflects this. In such a case, Perian only handles decoding of the video, not the file format.

comment:4 in reply to: ↑ 3 Changed 7 years ago by Adreitz

I forgot to mention that I did NOT see this problem with 0.5. It only cropped up with the beta 1.0 builds, and is still in the final. I probably updated QT sometime in that range, so that might be part of it.

As a test, I did my procedure on five videos in a different, QT-native format (Sorenson Video 3). As above, I put them all in one video file, end to end without reencoding. I then watched Activity Monitor and the video stream carefully. There was NO delay, and no change in QT Player's CPU usage. With files made from VP6 video streams, though, I get the delay. What is weird is that CPU usage is LOWER during the delay than when the video finally starts playing (30% vs 43%, approximately).

I don't see this initial delay when playing a VP6 stream directly from an FLV in QT Player, but I always first wait for the progress bar to fill (since CPU usage is so high while the FLV is loading).

Perhaps Perian is asking QT to load VP6 video streams in a suboptimal way compared to other codecs. I don't know if this is related, but in Perian 0.5, FLVs would seem to load immediately and would be immediately playable in QT Player. I didn't have to wait for the progress bar to fill up, and CPU usage wouldn't spike. (Of course, 0.5 had other problems with FLVs, like incorrect height of the image.)

By the way, I don't quite understand his reply, but I don't think brilliantpebble actually understood what I was saying.

comment:5 follow-up: ↓ 6 Changed 7 years ago by brilliantpebble

Geez, well, I'm sorry if I got anything wrong, Adreitz. I'll happily admit that I am something of a newbie to all of this, and a casual user at best, so I may not be up on all of the technical details and specifics. (For instance, I didn't even think about CPU spiking in my original post, although I haven't noticed any.) But I was just trying to observe that I had encountered a similar problem with the same file type, only under a different circumstance in that I was not joining clips together as you were. I just thought I would contribute to the discussion because I wanted to give as clear a picture as possible, and this little problem has been driving me crazy, so I'm happy there is some discussion about it. But I guess I just made things less clear some how, so I'll just leave it to you experts to figure out.

comment:6 in reply to: ↑ 5 Changed 7 years ago by Adreitz

No, no, I wasn't trying to insult you or anything. Don't worry about it. It seemed from your first post that you thought I only had a single audio/video track pair in my .mov files or something.

Aaron

comment:7 Changed 4 years ago by astrange

  • Status changed from new to closed
  • Resolution set to duplicate

Probably a complaint that frame skipping in QT is too aggressive.

Note: See TracTickets for help on using tickets.