Ticket #35 (closed enhancement: fixed)

Opened 8 years ago

Last modified 4 years ago

no sound - AVI

Reported by: anonymous Owned by:
Priority: normal Milestone: 1.0
Component: Perian-Main Version:
Severity: normal Keywords:
Cc: marc@…

Description

Hello,

first i want to tell you that i like your plugin very much, i waited for something like that since 1 1/2 years, since i have a digital camera with video. It's a Pentax and the avi-films i made with it couldnt be played with quicktime, and therefor nor in the finder(Preview) or in iPhoto. Now this works great, but ... there is no sound. grrrr.... it could be so fantastic.... can you fix that??? i try to atach an short original film. Thank you for doing this great plugin

marc bodon

Change History

comment:1 Changed 8 years ago by marc@…

  • Type changed from defect to enhancement

i tryed to upload the videofile but its zu large (about 400kb). Now i uploaded it to my webspace:  http://www.marc-bodon.de/IMGP2223.AVI You have to download it , because the video is not playing in safari... maybe an other ticket ;-)

marc bodon

comment:2 Changed 8 years ago by tick

  • Cc marc@… added
  • Milestone 1.0 deleted

Try  http://trac.cod3r.com/a52codec/ and see if it works. I'll play around with it tonight if it does not.

comment:3 Changed 8 years ago by gbooker

The audio format here is "DVI ADPCM". Funny that QuickTime player knows that much, but it completely unable to play it. The A52codec listed above won't help here.

comment:4 Changed 8 years ago by dconrad

For some reason, the call to AudioFormatGetProperty?() for kAudioFormatProperty_FormatInfo is setting an incorrect value for asbd.mBytesPerPacket (1024 when it needs to be 512). I'm not sure of the correct way to fix this, though (maybe set asbd. mBytesPerPacket after the call instead of before?)

comment:5 Changed 8 years ago by tick

  • Milestone set to 1.0

Moving to 1.0 for now, but not a blocker.

comment:6 Changed 8 years ago by dconrad

  • Status changed from new to closed
  • Resolution set to fixed

(In [153]) Override the default information about a codec that the Audio Toolbox gives us, since it's probably more accurate. Closes #35

comment:7 follow-up: ↓ 8 Changed 7 years ago by anonymous

I have the same problem. But to be honest I am new to mac, I've had my mac for less than a week, and I would like to be able to play my pentax movies, so I was reading changeset 153, but don't quite understand what I should do. Hope you can help.

Thanks for the great forum and application.

comment:8 in reply to: ↑ 7 Changed 7 years ago by gbooker

Replying to anonymous:

so I was reading changeset 153, but don't quite understand what I should do. Hope you can help.

If you were the type to download the source and build it yourself, this means that if you get a revision greater that 153, you would have the fix. This also means that when a version is released which uses a source revision greater than 153, it will contain the fix. This requires waiting for version 1.0. Most people are in the second camp.

Essentially, we are saying that we have fixed the bug, and since this is an open source project, we are simply pointing out to other developers and others who are curious, where in the source we fixed it.

comment:9 Changed 7 years ago by anonymous

Hi,

Rebuilding from up-to-date source fixes this problem. I just thought I'd write a bit more about it for future reference, as well as for the newbies if they're still watching this. (FYI, I'm new to Macs as well, but I've come from a background heavy in Linux.)

I was having the same problem as the original poster was having. I have a Pentax Optio S5n digital camera and I've taken lots of video clips with it. The camera purports to record video clips as MPEG4, but in fact the resulting files are AVI files, using the 3ivX codec for video and a crude ADPCM codec for the onboard microphone. Normally, when I tried to play these in QuickTime, I got audio but no video. Someone put me onto Perian, but after I installed Perian 0.5, I got video but no audio.

However, I now have a new version of Perian (revision 496) that I built myself, and I now get both audio and video. The procedure is pretty simple: get the source code with Subversion, run "make", and copy the Perian components to /Library/QuickTime?.

Part of the need to use Perian for this stems from the lack of an official 3ivX component that runs on Intel Macs (version 4.5.1 in only available for PowerPC). However, I can now play the AVI files that my Pentax creates directly in QuickTime (and iMovie, and probably everything else). I can't speak for the Perian people about when a new version will be coming out, but I can confirm that the current source code fixes this problem.

Anyway, I don't know whether this has helped anyone, but I for one am extremely grateful that this has been solved. If there are still newbies reading this and still thinking that it's a foreign language, send me email and I might be able to help you out further.

Best wishes,

Aaron Nielsen (roesti AT f2s DOT com)

comment:10 follow-up: ↓ 11 Changed 7 years ago by tick

We would prefer that those who require further explanation ask their questions either on trac or the discussion list. Please do not ask our users to contact you directly in the future. I know you mean well, but this doesn't help you or us.

comment:11 in reply to: ↑ 10 Changed 7 years ago by anonymous

Replying to tick:

We would prefer that those who require further explanation ask their questions either on trac or the discussion list. Please do not ask our users to contact you directly in the future. I know you mean well, but this doesn't help you or us.

I only suggested it because I was worried that a fellow newbie might ask questions that were a bit too simple to be relevant to the ticket. Anyway, please accept my apologies.

Best wishes,

Aaron

Note: See TracTickets for help on using tickets.