Ticket #500 (closed defect: invalid)

Opened 5 years ago

Last modified 3 years ago

Quick Look hangs on MKV thumbnail load

Reported by: Bonatapus Owned by:
Priority: normal Milestone:
Component: matroska Version: 1.2.1
Severity: normal Keywords:
Cc:

Description

When Quick Look Helper tries to load thumbnail previews for MKV files while Perian is installed, it hangs consuming around 30% of the CPU until it times out and places a generic icon instead of a frame from the video as the thumbnail. This process is visible when viewing an MKV in a stack on the dock; the thumbnail will be blank (represented by a dotted line square) and when Quick Look Helper finally times out it will place the generic icon there instead. Uninstalling Perian fixes this issue because Quick Look no longer acknowledges MKV's as something that it can preview. This happens regardless of the program set to default for MKV files. This is an issue because while Quick Look Helper is trying to generate the thumbnail preview for the MKV it will not generate other thumbnails until it times out, not to mention the increased CPU and RAM usage.

Attachments

Timeout.log Download (189 bytes) - added by Bonatapus 5 years ago.
Console log of Quick Look Helper timing out.

Change History

Changed 5 years ago by Bonatapus

Console log of Quick Look Helper timing out.

comment:1 Changed 5 years ago by Bonatapus

In order to reproduce this effect the file must not already have had a thumbnail generated for it by Quick Look Helper. Move the file to a different location or relog to see the effect take place.

comment:2 Changed 5 years ago by gbooker

  • Milestone set to Needs Feedback From User

We need a sample to proceed further. This is likely due to limitations in QuickTime's architecture, in which case there is nothing we can do.

comment:3 Changed 4 years ago by hooger

I have the same issue. What can I do to help?

comment:4 Changed 4 years ago by astrange

Try running Spin Control and see if it generates a log for quicklookd. It's in the OS X Developer Tools.

I'm pretty sure I know the cause for this one, though. Can't think of any solution…if we can tell we're being used for thumbnailing inside the demuxer, we could stop after importing one displayable frame. But I don't see how to do that - checking the process name probably won't work.

comment:5 Changed 3 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Needs Feedback From User deleted

No response; closing

Note: See TracTickets for help on using tickets.