Ticket #572 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

WebM videos don't play in Safari

Reported by: Rik Owned by: astrange
Priority: normal Milestone: 1.2.3
Component: PrefPane Version: 1.2.2
Severity: normal Keywords:
Cc:

Description

I have Perian 1.2.2 installed and I can play WebM videos with Quicktime. But Safari (5.0.5) does not play WebM videos.

In Help>Installed plugins, I see "QuickTime Plug-in 7.6.6" but not the mime types supported by Perian.

I've filed  https://bugs.webkit.org/show_bug.cgi?id=58586 on the WebKit? side.

Change History

comment:1 Changed 3 years ago by astrange

We have an mcfg resource with video/webm and video/x-matroska registered. It doesn't seem to be showing up in Safari -> Installed Plug-ins. I'll compare the rez files with XiphQT.

comment:2 Changed 3 years ago by astrange

  • Owner set to astrange
  • Status changed from new to assigned

I don't see any relevant differences. May need to consult a QT person on this.

comment:3 Changed 3 years ago by astrange

Deleting ~/Library/Preferences?/com.apple.quicktime.plugin.preferences.plist fixes it.

Possibilities:

  1. report as a bug against the QT plugin, if the webkit bug doesn't get someone to do it.
  1. Delete part of that file when installing Perian.

comment:4 Changed 3 years ago by Rik

I deleted this file but it still does not work for me. I can see the webm config when I open the .plist but Safari and the latest WebKit? nightly does not play the video. No sign of webm in "Installed plug-ins"

comment:5 Changed 3 years ago by astrange

You see video/webm in that plist but not in Installed plug-ins? That's certainly a plugin problem, but I don't have further solutions. Look for other QuickTime preferences files, I guess.

comment:6 Changed 3 years ago by astrange

  • Component changed from Perian-Main to PrefPane
  • Milestone set to Next Fix

Let's do #2. But when installing in /Library should we really delete it for all users…?

comment:7 Changed 3 years ago by astrange

Oh we can't do that because of FileVault. That's easy, but it means the QuickTime plugin needs to deal with it.

comment:8 follow-up: ↓ 10 Changed 3 years ago by Rik

Someone also commented about "canMovieImportPartial" (see  https://bugs.webkit.org/show_bug.cgi?id=58586#c19)

If there is a trunk version of Perian that I should test, please let me know.

PS : Is there a way to receive a mail after each comment? Can't find this in prefs.

comment:9 Changed 3 years ago by tick

  • Milestone changed from Next Fix to 1.2.3

comment:10 in reply to: ↑ 8 Changed 3 years ago by tick

Replying to Rik:

PS : Is there a way to receive a mail after each comment? Can't find this in prefs.

You can be added to the cc line if you'd like, or you can add your email to your account preferences and it *should* work. I don't know that it does though.

comment:11 Changed 3 years ago by astrange

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [1450]) Delete the user's QT web plugin cache after installing

Fixes #572

Note: See TracTickets for help on using tickets.