Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#556 closed defect (fixed)

240p FLV html stream issue

Reported by: ball Owned by:
Priority: normal Milestone:
Component: Perian-Main Version: 1.2.1
Severity: normal Keywords:
Cc:

Description

Hi! I have an odd, annoying problem which I *think* is due to Perian.

When I use click2flash to play FLV html streams, everything works great unless I choose 240p, in which case only the first few seconds will be downloaded.

How to reproduce:

1) Install Perian 1.2.1 and click2flash 2.1.3

2) Go to any youtube site, such as http://www.youtube.com/watch?v=gq--g4zIuNA

3) Hover in the top-left of the video view. A menu should pop up showing what streams are available. Choosing any stream but 240p works, but with 240p only a few seconds will play. Right-clicking the window and loading the flash player will allow the 240p video to be played, but this defeats my purpose for using c2f. Right-clicking the 240p stream provides the option of downloading that stream which I can play in QuickTime using Perian, but then I have to download the entire video.

My suspicion is that Perian is reporting the wrong length of the video when the header is downloaded.

Change History (7)

comment:1 Changed 7 years ago by ball

PS: Using Snow Leopard 10.6.6

comment:2 Changed 7 years ago by gbooker

  • Resolution set to fixed
  • Status changed from new to closed

Cannot reproduce any issue at all using 1.2.2b1 announced in the mailing list: http://groups.google.com/group/perian-discuss/topics

Closing as fixed unless told otherwise.

comment:3 Changed 7 years ago by ball

Hm, for some reason I didn't get any email notification of your reply.

Anyway, I can confirm this is fixed in 1.2.2 beta 1! Thank you!

comment:4 Changed 7 years ago by ball

I dunno man, I'm still getting problems with videos like this one:

http://www.youtube.com/watch?v=JgdYMi_koEU&feature=player_embedded

If this one works with you, gbooker, I'd be interested to know.

comment:5 Changed 7 years ago by ball

PS: Is there any way to subscribe to this ticket (get email updates)?

Also, any way to bump the version of the bug to 1.2.2b1 or should I make another?

comment:6 Changed 7 years ago by ball

OK, I STILL have errors with the original link! It seems to be completely random whether or not it will load properly

comment:7 Changed 7 years ago by gbooker

Still cannot reproduce. Not even once.

Note: See TracTickets for help on using tickets.